Sunday, September 28, 2014

Another Appfabric installation error due to PSModulePath


Product: AppFabric 1.1 for Windows Server -- Error 1722. There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor.  Action Env_PSModulePath_powershell_i, location: C:\Program Files\AppFabric 1.1 for Windows Server\Microsoft.ApplicationServer.InstallHelper.exe, command: powershell.exe "-command \"$str = [System.Environment]::GetEnvironmentVariable(\\\"PSModulePath\\\",[System.EnvironmentVariableTarget]::Machine); $str = $str+\\\";C:\Program Files\AppFabric 1.1 for Windows Server\PowershellModules\\\"; C:\Windows\system32\setx.exe /MPSModulePath \\\"$str\\\"\"" "C:\Users\senthil\AppData\Local\Temp\AppServerSetup1_1_CustomActions(2014-09-28 20-02-35).log"

Unable to proceed the installation after restarting the Server by AppFabric.


You will this error during the installation of Appfabric service in SharePoint server 2013. You need to fix 2 issues. 
  1. Need to update the "PSModulePath" in the environment variable section
  2. Enable the "Windows Firewall" service


1. "PSModulePath" in the Environment variable will have extra double quote (") at end of the value. Appfabric installation will not be able to parse the value, if it contains the double quote. So we need to remove that additional character.   Follow the below screenshots to remove the extra double quote character

2. One more important thing is, we need to enable to the "Windows firewall" service which is mandatory for Appfabric to complete its full installation. Because

Appfabric will try to add few entries in the Windows firewall.  See the below screenshot for more info.

(This second one has killed me a lot)

No comments:

Post a Comment